Welcome to Emulationworld

Forum Index | FAQ | New User | Login | Search

Make a New PostPrevious ThreadView All ThreadsNext ThreadShow in Flat Mode*


SubjectPSP : a newbie question Reply to this message
Posted byKarLKoX
Posted on07/01/05 07:42 PM



Hi ! I ve a very stupid question for my first post ^_^ : i ve just downloaded the opensource sdk and get compiled the sample (gcc 4.0).
Is it normal that it doesn't work with PSPE (the PSP emulator) ?
I also tried a hello world ( http://sec.pn.to/pub/hellopsp_src_Rel1.zip ) wich was originaly coded for the PSP hardware, i ve modified the source to use the PSP SDK kernel functions, got it compiled too and here, i ve a crash debug.
As i am not a debugging freek, here it is :

load EBOOT.PBP
PBP format
psppath:(null)
9fffc00
illegal address
PC = 00000000
00000000 00000000 00000000 00000000
00000000 00000001 09fffc00 00040000
80000000 00000000 00000000 00000000
00000000 00000000 00000000 00000000
00000000 00000000 00000000 00000000
00000000 00000000 00000000 00000000
00000000 00000000 00000000 00000000
77d18bd9 09fffbf0 00000000 00000000

As you can see, it seems to be before any emulation (PC = 0) so i think that (perhaps) the SDK produce weird binaries (header corrupted or so). Am i wrong ? (i should ^_^)
Any help would be much appreciated :)




-
Entire Thread
Subject  Posted byPosted On
.PSP : a newbie question  KarLKoX07/01/05 07:42 PM
.*Re: PSP : a newbie question  Tourniquet07/02/05 06:25 PM
..*Re: PSP : a newbie question  KarLKoX07/02/05 07:33 PM
...*Re: PSP : a newbie question  smf07/04/05 03:44 PM
....*Re: PSP : a newbie question  black_smith10108/04/05 02:09 AM
.....*Re: PSP : a newbie question  smf11/01/05 02:09 AM