Forum Index | FAQ | New User | Login | Search

Make a New PostPrevious ThreadView All ThreadsNext Thread*Show in Threaded Mode


SubjectChip 8 help Reply to this message
Posted byRockerSKingdom
Posted on10/09/07 01:33 PM



Ok, here are some pictures of chip 8 emualtor I programmed.

http://i2.photobucket.com/albums/y6/pradipna/chip81.jpg
http://i2.photobucket.com/albums/y6/pradipna/chip82.jpg
http://i2.photobucket.com/albums/y6/pradipna/chip83.jpg
http://i2.photobucket.com/albums/y6/pradipna/chip84.jpg
http://i2.photobucket.com/albums/y6/pradipna/chip85.jpg

The problems are in graphics.

I programmed it in VB so if anyone could I would appreciate that...







SubjectRe: Chip 8 help new Reply to this message
Posted byJonemaan
Posted on10/11/07 06:25 AM



Please take the time to read through this thread: http://www.emutalk.net/showthread.php?t=19894
To get you started, yes it looks like a graphics problem. CHIP8 sprites are drawn with a simple XOR rule. This means that if a solid pixel is drawn over a solid pixel, the pixel will be erased.

> Ok, here are some pictures of chip 8 emualtor I programmed.
>
> http://i2.photobucket.com/albums/y6/pradipna/chip81.jpg
> http://i2.photobucket.com/albums/y6/pradipna/chip82.jpg
> http://i2.photobucket.com/albums/y6/pradipna/chip83.jpg
> http://i2.photobucket.com/albums/y6/pradipna/chip84.jpg
> http://i2.photobucket.com/albums/y6/pradipna/chip85.jpg
>
> The problems are in graphics.
>
> I programmed it in VB so if anyone could I would appreciate that...
>





Previous ThreadView All ThreadsNext Thread*Show in Threaded Mode