Welcome to Emulationworld

Forum Index | FAQ | New User | Login | Search

Make a New PostPrevious ThreadView All ThreadsNext ThreadShow in Flat Mode*


SubjectAdvancemenu and Daphne Reply to this message
Posted bysphincter
Posted on11/01/05 12:49 PM



Asking this here because I've been banging my head on and off with this for a couple of weeks now, and am hoping someone who's been through the same situation can help.

I've got Advancemenu running in my MAME cabinet. xmame-0.101 is picked up by it and launches fine. Daphne, however, is being difficult to say the least. Daphne works OK from the commandline, so this seems to be a problem with the interaction between Daphne and Advancemenu. What I'm trying to accomplish here is having the list games supported by Daphne integrated with the list of games supported by xmame so that everything can be started from the same menu. Here's what I've tried so far:

Following the instructions at Aaron's MAME'd Millipede Site, I added the following lines to advmenu.rc (here tweaked for Daphne 0.99.7 and my configuration):

emulator "Daphne" generic "/mnt/daphne/daphne" "bega vldp"
emulator_roms "Daphne" "/mnt/daphne/roms"
emulator_titles "Daphne" "/mnt/daphne/titles"
emulator_altss "Daphne" "/mnt/daphne/pics"
emulator_include "Daphne"

This puts Bega's Battle into the Advancemenu list and does start it correctly - but that's only one game. There are 25 I want to add, and would prefer to not have to define each one individually in advmenu.rc.

So, moving on, the Advancemenu readme says (in section 4.1):

"If you want, you can manually write a MAME like information file and name it as `ENUNAME.lst'. This file has the same format of the output of the `-listinfo' MAME command. Actually only the information `game', `name', `description', `year', `manufacturer', `cloneof' are used. Please note that this file is used only to add information at the existing games. The games present in this file are not automatically added at the game list."

Okay. So having removed my earlier edits, I create a Daphne.lst file in the same directory as advmenu.rc. This file contains a list of the games supported by Daphne I want to add in to the menu, using the following format per game:

bega, Bega's Battle, Laserdisc, 1983, Data East,

Then, in advmenu.rc, I also add the following:

emulator "Daphne" generic "/mnt/daphne/daphne" " vldp"
emulator_roms "Daphne" "/mnt/daphne/roms"
emulator_titles "Daphne" "/mnt/daphne/titles"
emulator_altss "Daphne" "/mnt/daphne/pics"
emulator_include "Daphne"

What happens here is that Advancemenu reads the Daphne.lst file, adds each game to the menu but only as its ROM name - so instead of appearing in the list as 'Bega's Battle', the game comes up as 'bega'. I've tried playing with the positioning of the different fields to no avail.

Further, Daphne doesn't start - you can select the game, but the emulator never launches. Unfortunately, I don't get to see any actual error messages and the Daphne log is strangely silent.

My guess is that Daphne's being passed a bad parameter by Advancemenu, but I can't see what it is. Does anyone else who has run into this have any ideas? It's really starting to annoy me.

-
Entire Thread
Subject  Posted byPosted On
.Advancemenu and Daphne  sphincter11/01/05 12:49 PM
.*Re: Advancemenu and Daphne  fred12345606/30/06 01:38 PM